DragonFly 5.8 released!

DragonFly 5.8.0 has been released.  This version brings dsynth, with matching optimizations to fit dsynth running many parallel builds of ports.

My users@ post has the usual details on upgrading, as do the release notes.

Note that you will get some noise in dmesg until you remove opie from where it’s mentioned in /etc/pam.d/ files.  It’s cosmetic unless you use opie, and you probably don’t.  I mention it because I noticed it.  Check /usr/src/UPDATING after pulling in the 5.8 source to see details of this and other changes.

8 Replies to “DragonFly 5.8 released!”

  1. Woohoo! Thanks for continuing the schedule of regular releases. Now I have to find a suitable machine to try it on. Thanks.

  2. It does not compile !
    make buildworld fails while compiling flex:
    misc.o:misc.c:function allocate_array: error: undefined reference to ‘reallocarray’
    misc.o:misc.c:function reallocate_array: error: undefined reference to ‘reallocarray’
    Am I the only one with this problem ?

  3. Jean-Marc – I haven’t seen that while building multiple 5.8 machines. Is this a 5.6 system you are using for this?

    My first hunch is to say get rid of /usr/src, then in /usr type ‘make src-create’, then go through the steps for upgrade, just to be sure it’s clean. Dunno if that will help, but it provides a “clean” base.

  4. Justin, my system is a 5.4.1
    I already tried to get rid of /usr/src/ and ‘make src-create’.

  5. Maybe I should first upgrade to 5.6.2 (which I know compiles on my system) and then try 5.8.
    I just hoped that the upgrade would nonetheless work.
    By the way the handbook does not explain how to upgrade jails (neither in the upgrading nor in the jails sections)
    Therefore when I upgraded my system for the first time, my jails did not work anymore (thank you hammer for the snapshots ;)
    What would be the recommended, reliable, way to upgrade jails ?
    All the methods I’ve found are from FreeBSD and I mix some of them to make the upgrades. An “official” way of making it would be welcome

  6. Sorry for the dumb question.. after upgrading I’m getting lots of problems.

    Is it possible to go back to 5.6 simply switching to the old git branch DragonFly_RELEASE_5_6 and repeating the build/install procedure?

    Or 5.8 libraries will be left around?

  7. I think you can go backwards to 5.6 – though I have not tried it. I had trouble building the 5.8 release on a 5.6 system, but that’s a different process.

    I have not worked enough with jails to know how to upgrade. If you find a way that works for you, please write it down on the site; others could use it, I’m sure.

Comments are closed.