Binutils changeout

DragonFly has had binutils 2.24 and 2.25 both available for some time.  2.24 has been taken out and replaced by binutils 2.27, thanks to Rimvydas Jasinskas.

The 2.25 version was and still is installed by default.  If you want to try out 2.27 instead, WORLD_BINUTILSVER=binutils227 is what you need.  I didn’t test that, of course.  The binutils changelog will tell you what’s different in 2.27.

7 Replies to “Binutils changeout”

  1. Can we expect the gcc 4.7 branch to be replaced by the 6.x branch sometime soon?

  2. I haven’t heard anyone mention an intent to do anything with elftoolchain, though I wouldn’t necessarily know.

    DragonFly usually has two working compilers in base at a time; I think gcc 4.7 will be replaced with clang. I’m not doing the work, so take my assumptions with a grain of salt.

  3. I’d personally like to see -Wl,-z,relro,-z,now and -fstack-protector-strong enabled everywhere in base and DPorts. HardenedBSD already does it.

  4. To be honest, I don’t know. I won’t be in front of a DragonFly system for a few weeks.

Comments are closed.